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I. Product Introduction

The Handheld Stamp Printer enables portable and contactless inkjet marking in

multiple formats, including text, 2D codes, barcodes, images, timestamps, serial

numbers, database and counters—making it ideal for Identification, labeling,

logistics, asset tracking, and warehouse operations.

It prints reliably on a wide range of surfaces such as paper, plastic, metal, wood,

and other materials. Built on Linux the device features a 4.3-inch touchscreen

with multilingual interface and input support, allowing users to easily edit

content, configure settings, and manage print tasks. Select models include a

built-in scanner for direct data input via 2D codes or barcodes scanning.

II. Safety Instructions

To ensure safe operation and prevent personal injury, please follow the safety

guidelines below:

2.1 Electrical Safety

Before use, make sure the power outlet is properly grounded.
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Do not use non-original power adapters, as they may cause voltage instability

or device damage.

Do not operate the device in damp environments to avoid the risk of electric

shock.

2.2 Operational Safety

Once powered on, the printer must not be disassembled by untrained or

unauthorized personnel.

Install ink cartridges according to the instructions to avoid incorrect insertion or

damage to the cartridge chip.

Do not touch the printhead area during printing to prevent contamination or

print quality issues.

2.3 Ink Safety

Store ink in a cool, dry place away from direct sunlight or high temperatures

(above 35°C).

If ink comes into contact with skin or eyes, rinse immediately with clean water

and seek medical attention if necessary.

Use only original ink and accessories. Non-specified models may result in poor
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print quality or device malfunction and are not covered under warranty.

III. Device Composition and Interface

Description

3.1 Product Diagram
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Ⅳ. Ink Cartridge Compatibility

Different printer models support different ink cartridge sizes. There are two

cartridge size options available: half-inch and one-inch cartridges. Please select

the appropriate cartridge size based on your device model to ensure proper

installation and printing performance.This printer supports only original

cartridges with smart chips to ensure print quality and reliable performance.

4.1.1 Cartridge Size Compatibility

B71 / B71S: Supports only 0.5-inch cartridges

B71X / B71XS: Supports only 1-inch cartridges

4.1.2 Cartridge Print Specifications

0.5-inch Cartridge: Max print height 12.7 mm; Min character height 0.8 mm; Up

to 5 lines

1-inch cartridge: Max print height 25.4 mm; Min character height 1.6 mm; Up to

10 lines

4.1.3 Ink Type Selection
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Choose ink type based on the printing substrates:

Water-based cartridge: For porous materials like paper, cartons, wood, and

fiberboard.

Solvent cartridge: For non-porous materials like plastic, glass, foil, and

laminated cartons.

Available Colors: Black, White, Red, Yellow, Blue, Green, Security Color.

Cartridge Capacity: 42 ml.
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Ⅴ. Product Specifications
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Ⅵ. Setup Instructions

Before using the device, please complete the following preparation steps.

Step 1: Unpack and check contents

Verify the package includes the following items:

 Printer x1

 Ink cartridge x1

 Power adapter x1

 USB flash drive (for file import)x1

 LED screen stylus pen x1

Step 2：Power on

Connect the power adapter to an outlet. The device can run on external power

or its built-in battery.

Press and hold the power button until the screen turns on and the home

interface appears.

Step 3: Install the Ink Cartridge

Open the cartridge compartment cover.



12 / 50

Insert the cartridge into the cartridge slot until you hear a “click,” indicating

proper installation.

Once recognized, the screen will confirm cartridge detection and automatically

apply matching settings.

Step 4: Set System Language and Time

Tap System Settings → Language Settings to set your system language.

Tap System Settings → Time Settings to set and calibrate system time.

Step 5: Print Test

Tap Edit → Add Text → Enter text for test.

Click Print then Press the Print button to start printing.

Check whether the print output is clear and properly positioned.
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Ⅶ. Main Interface

The main interface features six core modules: Edit, Management, Device Info,

System, U-Disk and Maintenance.

Edit: Create and edit print files with support for text, 2D codes,barcodes,

images, counters, and databases.

Management: Supports grouped printing settings and allows deletion or

renaming of saved job files.

U-Disk: Enables import and export of job files, images, databases, and fonts for

easy cross-device sharing and backup.

System : Configure print and cartridge parameters, and adjust basic settings

such as system time, language, and power management.

Device Info: Displays key details such as model, serial number, firmware version,
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and battery status, along with print count, ink level, and droplet data for

effective monitoring and maintenance.

Maintenance: Provides nozzle cleaning, print testing, and firmware updates to

ensure stable operation and optimized performance.

7.1 Create a new print file

New: From the main interface, tap Edit →File to open a blank canvas. At this

point, no print objects are present, and you can begin adding and editing

content.

Open: Tap File → Open. A prompt saying “Searching for files, please wait” will

appear. The system will scan local storage and display a list of available files for

editing.

Save: After finishing the print message editing, tap Save, enter a file name in
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the pop-up dialog, and the content will be saved.

Save as: Enter a new name to save the file as a new copy, leaving the original

file unchanged.

Delete: Tap Delete to remove the currently opened file or objects on the

canvas.

7.2 Add

You could insert various object types, including text, time, 2D codes, counter,

barcodes, databases, and images. You can also Scan to capture barcodes or QR

codes from physical items for editing and printing.
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7.2.1 Add a Text

Text Settings

Font:The default font is Yahei. Additional external fonts can be installed. For

detailed instructions on installing external fonts, refer to Section 8.3.

Font Size: Default height is 12.7 mm for half-inch cartridge models and 25.4 mm

for one-inch models.

Spacing: Character spacing is adjustable. Default is 0 mm; enter a value to

modify.

Rotation: Applies overall rotation to the content. Default is 0°; enter a value to

adjust.

Flip : Horizontal and vertical mirroring can be enabled via tapping icons.

Single Character Rotation: Default is 0°; individual characters can be
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rotated by entering a value. When enabled, italic style becomes unavailable.

Font Style: Supports bold, italic, underline, and strike-through formatting.

7.2.2 Add a 2D code

You can either manually enter a string or import data from a database to

generate variable 2D codes in sequence.To add a database, please refer to the

instructions in Section 8.2 and 7.2.7.

Tap Add then select 2D Code. Enter the string in the text field to generate the

code. Below the preview panel, choose the encoding format and configure

relevant parameters. Once finished, tap Confirm to place the generated QR

code onto the canvas.

Encoding Format: Supports QR, DM (Data Matrix), and GS1 DM (GS1 Data

Matrix).
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Text: Enter the string to generate the QR code.

Size: Sets the QR code size. Default: 12.7 mm for half-inch cartridge based

printer models, 25.4 mm for one-inch cartridge based printer models.

Rotation: Angle range: 0°–360°, default is 0°. Changes are reflected in the

preview.

Margin: Sets the blank area around the QR code. Range: 0–3 mm, adjustable in

0.1 mm increments.

7.2.3 Add a Barcode

You can either manually enter a Barcode string or import data from a database

to generate variable Barcode in sequence.To add a database, please refer to the

instructions in Section 8.2 and 7.2.7.

Tap Add and select Barcode. Choose the encoding Format and enter the
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barcode string in the text field to generate the barcode. Configure the relevant

barcode parameters as needed. Once the settings are complete, tap Confirm to

place the generated barcode onto the canvas.

Format: Select the supported barcode encoding format from the dropdown

menu.

String: Tap to enter the barcode string. Input must comply with the selected

barcode format standards.

Barcode Preview: Displays a real-time preview of the entered barcode content.

Height: For half-inch models, the height range is 5 mm to 16.9 mm; for one-inch

models, 11.8 mm to 56 mm. Default values: 12.7 mm (half-inch), 25.4 mm

(one-inch).

Width: Both half-inch and one-inch models support a width range of 25.4 mm

to 169.3 mm, adjustable in 0.1 mm increments. For standard EN13 barcodes, the

default length is 39.7 mm with a default font size of 2.5 mm. As character count

increases, barcode length expands automatically per standard specifications.

Margin: Sets the blank space between the top of the barcode and the print

editing frame. For half-inch models, the range is 0–5 mm; for one-inch models,

0–10.1 mm. Adjustment unit: 1 mm. Default: 0 mm.
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String Position: Tap the string icon to configure string position and size. Default

position is below the barcode. Options include: string below, string above, or

Invisible (hidden). The string is positioned 2 mm from the barcode.

String Size: For half-inch models, the default string height is 3 mm, adjustable

from 1 mm to 5 mm in 0.5 mm steps. For one-inch models, the default is 6 mm,

adjustable from 1 mm to 10 mm in 0.5 mm steps.

7.2.4 Add an Image

When adding an image, ensure it meets the required format and size

specifications. For preparation steps and import procedures, please refer to

Section 8.1.
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File: After inserting a USB drive containing image files, tap U-Disk on the main

interface, then select Import – Image. A file list will appear, displaying the

filenames and format details of the available images.

Image Preview: Displays the image content. The image size dynamically adjusts

based on the zoom ratio.

Scale X: Adjust the horizontal ratio from 10% to 300%. Users can enter values

directly in the input field (step size: 1). The default value corresponds to the

image’s original width.

Scale Y: Adjust the vertical ratio from10% to 300%. Users can enter values

directly in the input field (step size: 1). The default value corresponds to the

image’s original height.

Lock Aspect Ratio:When enabled, horizontal and vertical scaling remain

proportional. Adjusting one dimension automatically scales the other

accordingly.

Search: You can find images by entering the image file name.
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7.2.5 Add Time

Production Date: Can be manually modified after selection. Defaults to the

device system time.

Year/Month/Day & Hour/Minute/Second: Date and time components can be

edited separately. Default values are based on the device’s current system time.

Expiration Date: Can be manually modified after selection. Defaults to the

device system time.

Expiration Year/Month/Day & Hour/Minute/Second: Date and time

components can be edited separately. Defaults to the device system time.

Date Format: Default format is YYYY/MM/DD. Other formats can be selected

via dropdown menu.

Auto Update:When enabled, date and time automatically sync with the system
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clock.

Calendar Type: Gregorian calendar is used by default. Options include

Gregorian, Hijri, Persian, and Julian calendars.

Time Format: Default format is HH:MM:S-24H. Other formats can be selected

via dropdown menu.

Leading Zeros: Controls how leading zeros are displayed in dates. Options can

be selected via dropdown menu.

Font Settings: Refer to the relevant section for details on font configuration.

7.2.6 Add a Counter

Counter Settings

Preview: Displays the current number. Size and style adjust automatically based

on the selected font.
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Start Value: Sets the minimum value of the counter.

End Value: Sets the maximum value of the counter.

Current Value: Sets the current printing number, which must fall within the

range of the start and end values.

Step Value: Sets the increment value for numbering. For example, if the step is

3, the sequence will be 1, 4, 7…

Radix : Default is decimal. Options include base 10, 12, 16, 32, and 36.

Leading 0:When enabled, leading zeros are added to fill the number to a fixed

length based on the selected base. For example: 1 → becomes 0001 when

leading zeros are enabled; 1555 → becomes 1GJ in base 32, and 01GJ with

leading zeros enabled (based on the digit length after base conversion).

Auto Increment/Decrement: Allows automatic increase or decrease of the

counter.

Print Count: Sets how many times the current number should be printed.

Default is 0.

For text settings, please refer to the relevant Section 7.2.1.

7.2.7 Add a Database

This interface allows variable data printing by importing a database, including
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variable text, variable QR codes, and variable barcodes. For details on how to

import a database, please refer to Section 8.2.

After selecting the target file, choose the desired output type from the

Encoding Type drop-down menu—Text, QR Code, or Barcode. Then click

“Confirm” to proceed to the next step.

If the file format is valid, the system will proceed to the next interface; otherwise,

a “Database file format error” message will appear. In the next interface, the

database content will be displayed in a list format, supporting up to three

columns. Select the desired column and tap Confirm to enter the following

interface.
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Preview : Displays the first row of data from the selected database column.

Start Row Number: The default value is 1 and can be adjusted by Taping, in

increments of 1.

End Row Number: The range is determined by the maximum row number of the

selected column and can also be adjusted by Taping, in increments of 1.
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7.2.8 Add Scanning Content

Scanning content can be added via the scanning module. This feature is only

available on printers equipped with a scanning module.

Tap Edit → Add → Scan to enter the scanning interface. Align the module

with the code and press Print button. If scanning fails or no content is detected,

a prompt will appear. Press Print button again to retry. Upon success, the

system proceeds automatically.
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After a successful scan, select the desired output coding format by taping Type

—Text, 2D Code, or Barcode—from the encoding type drop-down menu. Tap

Parameters to edit the generated format.

7.3 Print Setting

This interface allows you to configure grayscale levels, resolution, print position,

printhead flip, and cartridge parameters. For 1-inch cartridge based printer

models, Pallet QR code printing settings are also available here.

Note！The print settings here apply only to the currently edited file. To configure

system-level print settings, go to System Settings → Print Settings.

7.3.1 Configuration Panel for B71/B71S
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7.3.2 Configuration Panel for B71X/B71XS

Grey Level: Five levels available, Level 3 is default. Lower levels mean lighter

prints and less ink use.

Resolution: 0.5-inch cartridge models support 300 DPI and 600 DPI (default:

300 DPI). 1-inch cartridge models support only 300 DPI.

Nozzle Selection: Choose left or right nozzle row for printing; default is left.

Switch if issues occur. Not available on 1-inch cartridge models.

Print Location: Sets the starting position of the printed content—horizontal

and vertical alignments can be adjusted.

Cartridge Parameter Settings: Used to configure the pulse width and voltage

of the cartridge. Once installed, the device automatically detects and applies the

appropriate settings—manual adjustment is typically unnecessary.
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Printhead Flip: Supports horizontal and vertical mirroring. When enabled, print

content remains unchanged—only the printed output is affected. Horizontal

mirroring flips the print left to right; vertical mirroring flips it top to bottom.

Pallets QR Printing: Used for printing 2-inch QR codes on pallets, this function

requires dedicated fixture and is only supported on 1-inch cartridge-based

printer models.

Once enabled, the system navigates to the main interface, where a dashed line

divides the canvas into two lanes: Lane 1 and Lane 2. Users may tap either lane

to print it individually. If no selection is made, the system defaults to printing

Lane 1 first, then prompts “Please move the fixture” before proceeding to Lane

2.
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7.4 Edit

interface allows fine-tuning the position of editing objects on the canvas,

modifying their content, and adjusting aspect ratio, overall rotation, or text

orientation.

Shift: Select an object first, then use the arrow icons to move it precisely in any

direction. Each adjustment step is 0.1 mm. To exit fine-tuning mode, Tap

anywhere outside the adjustment panel.

Modify:When Taped, an editing panel will appear based on the selected object

type, allowing content adjustments.

Adjust： The Lock function maintains the object’s aspect ratio.Tap the icon

again to unlock and adjust the ratio freely. Rotate applies overall rotation, while

Text Rotate is only available for text objects and is not supported for other

types.
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Ⅷ. U-Disk

After plugging in a USB drive, you can import job files, images, databases, and

fonts. Before importing, place the files into the correct folders in the root

directory of the USB drive. If it’s a third-party USB, insert it into the printer and

format it first to create the necessary folders.
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8.1 Image Import

Step 1: Preparation Before Importing Images: You can use the built-in Paint

tool in Windows to add an image to the file, then Tap Resize to modify the

image's pixel dimensions. The version of the tool and its usage may vary

depending on whether you're using Windows 7, 8, 10, or 11.

Image pixel modification: maximum vertical pixel count 150.

Save the image as BMP, JPEG, or PNG format and name the file with letters

or numbers.
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Step 2: Copy the image file to the pictures folder on the USB drive, then insert

the USB drive into the printer and conduct the image import operations.

8.2 Database Import

Step1 Database preparation :After entering the data in Microsoft Excel or WPS

Spreadsheet, save the file as either a Unicode (.txt) or CSV file, named with

letters or numbers. For CSV files, use UTF-8 format. For TXT files, save as

Unicode (.txt).

Use Windows Notepad to reopen the TXT file and then save it with BOM

encoding in UTF-8 format; if BOM is not available, use UTF-8 format.

Step 2: Copy the file to the Database folder on a USB drive, then insert the USB
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drive into the printer to conduct Database import operations.

8.3 Font Import

Step One: Download the TTF format fonts file and copy the fonts file into the
fonts folder on the USB drive.

Step Two: Insert the USB drive into the printer, then tap USB Disk → Import
→ Font. From the list, select the font you want to install, tap Confirm
Installation, and wait until the message “Font Installed Successfully” appears.
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8.4 Export

The primary and secondary interface layout of the export function is identical to

that of the import function, but the operational logic is reversed.

Ⅸ. System Setting

The system settings interface includes configurable options for time, language,

device reset, alert tones, cartridge management, power preferences, and print

parameters. Each setting allows users to customize operational behavior and

optimize device performance according to specific usage scenarios.
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9.1 Time Setting

This section allows users to configure the system date and time display format,

as well as adjust and calibrate the device clock.

9.2 Language Setting

This section allows users to select the system language from a drop-down

menu.
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9.3 Device Reset
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Reset System Settings: A confirmation prompt—“Please confirm whether to

restore default settings”—will appear. Upon confirmation, the device reverts to

its factory default configuration.

Clear Internal Memory: A confirmation prompt—“Please confirm whether to

clear internal storage”—will appear. Upon confirmation, all internal user data will

be erased.

9.4 Prompt Sound Setting

The Sound Prompt Settings interface includes seven configurable options:

master sound toggle, shutdown alert, touch feedback, print beep, low battery

warning, low ink warning, and scan success alert. When the master toggle is

turned off, all sound prompts are disabled. Only when enabled will individual

alerts function as expected.
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9.5 Cartridge Setting

The device automatically detects whether the cartridge is water-based or

solvent and applies the corresponding settings. Manual adjustment is typically

unnecessary.
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9.6 Power Setting

Positioning Light: The positioning light provides illumination to help accurately

locate the printing area.

Brightness Adjustment: Adjust screen brightness using a scale. Range: 10%–

100%, with a default setting of 60%.
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Screen Off During Printing:When enabled, the screen turns off automatically

during printing and turns back on after printing is complete.

Dim on Standby:When enabled, the screen dims to the lowest brightness after

a period of inactivity (default: 10 seconds). The timeout duration can be

customized or disabled.

Screen Off on Standby:When enabled, the screen turns off after a period of

inactivity (default: 1 minute) and wakes up upon user interaction. The timeout

duration can be customized or disabled.

Auto Shutdown:When enabled, the device powers off automatically after a

long period of inactivity (default: 1 hour). The timeout duration can be

customized or disabled.

Power Saving Mode: Enabled by default. When active, standby dimming,

screen-off, and auto shutdown settings can be modified. When disabled, these

options are locked and cannot be changed.

9.7 Print Setting

This Print Setting here is used to configure system-level print settings. The

print settings in Section 7.3 apply only to the currently edited file. The setup
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process is identical in both locations.To perform system-level configuration, use

this page. For file-specific print settings, go to Edit → Settings and follow

the steps outlined in Section 7.3.

Ⅹ. Management

The print management interface supports grouped print settings and file

management functions, including actions such as deleting and renaming files.

10.1 Group Print

Grouped Print allows users to edit a print group and execute sequential printing

of selected files.
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Add: Adds files stored in the device to form a print group. Maximum of 20 files

can be added

Delete: Removes the selected file.

Print: Executes printing, same as the Print button in the editing interface.

Move Up / Move Down: Adjusts the file order by shifting the selected item up

or down in the list.

10.2 Job Management

On the current screen, users can manage print files, including renaming or

deleting unnecessary files.
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Delete: Select the target file to delete.

Rename: Rename the selected file. Note: If multiple files are selected, only the

last selected file will be renamed.

ⅩⅠ. Device Info

On the current screen, users can view device information such as product model,

serial number, and firmware version. Ink-related data—including total print

count, remaining ink level, and ink dot count—is also available, along with

battery status for monitoring power levels and charging condition.
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Model: Displays the current printer model information.

Serial Number: Displays the unique serial number of the device.

Firmware Version: Displays the current firmware version. This information

updates after a firmware upgrade.

Ink Volume: Shows the current ink level of the cartridge as a percentage.

Number of Prints: Displays the total number of prints performed by the device.

This value does not change when the cartridge is replaced, as it reflects the

device’s print history rather than cartridge usage.

Ink droplets Count: Displays the total number of ink dots consumed by the

device.

Battery Status: Indicates the current battery status of the device, either

“Charging” or “Discharging.”
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Charge Count: Displays the total number of times the device has been charged.

Each plug-in or removal of the charging cable increases the count by one.

Remaining Power: Displays the current battery level using a green bar.

Percentage is hidden by default.

Percentage Display: Disabled by default. When enabled, the remaining battery

level will be shown as a percentage, including in the top-right corner of the

screen.

XⅡ. Maintenance

On this page, users can perform maintenance and testing operations for the

printer, including nozzle cleaning, nozzle testing, print testing, and carriage

motor testing. Firmware upgrades can also be carried out from this interface.
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Nozzle Cleaning: Requires a recognized cartridge to be installed. When

activated, all nozzles perform a mirrored cleaning operation. A popup will

display “Nozzle cleaning completed.”

Nozzle Test: Requires a recognized cartridge to be installed. Each Tap prints

one nozzle test page.

Print Test: Requires a recognized cartridge to be installed. Each Tap prints one

print test page.

Motor Test: Moves the cartridge carriage from right to the far-left print

position, then returns to its original position.

Firmware Upgrade: Insert a USB drive containing the upgrade version. On the

firmware upgrade screen, select the desired version and Tap Confirm. Do not

remove the USB drive during the upgrade. The indicator light will turn yellow

during the process. Once complete, the system will automatically restart to

finalize the upgrade.
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ⅩⅢ.Ink Cartridge Maintenance Guidelines

1. Extended Downtime

If the printer remains idle for more than 4 hours, remove the ink cartridge and

attach the original cartridge clip to prevent nozzle drying and ensure consistent

print quality.

2. Print Issues

If you encounter issues such as unclear printing or white lines, follow these

steps:

Step 1: Automatic Cleaning TapMaintenance → Nozzle Cleaning from the

main screen. The system will automatically eject a small amount of ink to

clean the nozzle.

Step 2: Manual Cleaning If the issue persists, manually clean the nozzle
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using a lint-free cloth. The cleaning method depends on the type of

cartridge:

For water-based cartridges:

 Use a dry lint-free cloth to gently wipe the nozzle.

 If needed, moisten the cloth with distilled or deionized water

and wipe gently.

For solvent-based cartridges:

 Use a dry lint-free cloth to wipe the nozzle.

 Alternatively, use a cloth moistened with high-concentration

alcohol or 98% IPA for more thorough cleaning.

 Wiping Technique Always wipe in the direction of the nozzle from top to

bottom. Avoid scrubbing or back-and-forth motion.

 Do Not Use Do not use tissues or lint-based cloths, as fiber residue may

clog the nozzle.
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